Trouble Applying a Template

Have a problem you need help with or just want to chat about something that doesn't fit in another group, post it here.
Post Reply
NickG
Posts: 5
Joined: Thu Jan 28, 2021 3:41 pm

Trouble Applying a Template

Post by NickG »

Hello fellow Sunapsis users!

We ran into an issue applying a template from an e-form the other day and I was wondering if anyone could explain what went wrong. The idea is for students to enter information in a text box, and that information is then turned into a note in their Sunapsis profile using a template. I have attached images of the template and e-form design. When we tested it out, a Sunapsis user with full permissions could apply the template, but another user without full permissions (images of permissions attached) could not apply the same template. Then, we removed the auto-approve extension we had on, and it worked fine for everyone.

What might have caused users without full permissions to be unable to apply the template?
Attachments
trouble1.PNG
trouble1.PNG (207.36 KiB) Viewed 997 times
trouble2.PNG
trouble2.PNG (78.82 KiB) Viewed 997 times
Roles5.PNG
Roles5.PNG (171.11 KiB) Viewed 997 times

User avatar
barnhill
Posts: 55
Joined: Wed Dec 04, 2019 2:24 am

Re: Trouble Applying a Template

Post by barnhill »

Hey Nick!

What's the size of those text only fields. I just saw something posted as a bug that said text longer than 5000 characters slows things down. I don't think you have them entering that many characters but wanted to check. I'm going to keep asking around about this as it's bizarro.

Have a great day!
Thank you,
Jodi

NickG
Posts: 5
Joined: Thu Jan 28, 2021 3:41 pm

Re: Trouble Applying a Template

Post by NickG »

barnhill wrote:
Thu Feb 04, 2021 4:28 pm
Hey Nick!

What's the size of those text only fields. I just saw something posted as a bug that said text longer than 5000 characters slows things down. I don't think you have them entering that many characters but wanted to check. I'm going to keep asking around about this as it's bizarro.

Have a great day!
Thank you for your response Jodi! The maximum length is set to 500, though our tests were just words like like "hello" or "hi".

cindyconlin
Posts: 8
Joined: Fri Jun 12, 2020 4:45 pm

Re: Trouble Applying a Template

Post by cindyconlin »

It might be worth checking to see if the user who cannot apply the template also has problems directly updating the table that the template wants to update. It may be that the template operates under the permissions of the user applying it, and so if that user couldn't directly update the table, neither will the template be able to.

NickG
Posts: 5
Joined: Thu Jan 28, 2021 3:41 pm

Re: Trouble Applying a Template

Post by NickG »

Cindy,

Thank you for the input, that's an interesting way to go about finding the issue I hadn't thought about!

The template is pushing into notes management, which all users have access to and can upload notes, so unfortunately I don't think that is the issue.

Post Reply